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On Windows Vista and newer devices, you will need to be logged on as the Full Administrator
or use the “Run as administrator” option when executing the installation file.

Note...

System/Hardware Requirements

GASWorkS™ will operate on any device configured to run Windows 8 through Windows 11. Best
performance will be achieved when using a device with elevated memory size and processor speed. The use
of a mouse or similar pointing device is recommended. The use of a touchpad or similar point devices is
discouraged.

The GASWorkS software will require a minimum of 37 MB of free hard disk space when installed. An
internet connection is required for the license management system and the use of the GeoMap functions.

Licensing System

GASWorkS uses an internet-based licensing system. The software can be installed on any number of devices.
License information is stored on a B3PE server. When a User attempts to use the software, the license
availability is checked on the server. If the number of “in-use” licenses is less than the purchased number
of licenses (the User Limit), the User is allowed to continue; otherwise, the use of the software is denied until
the number of “in-use” licenses is below the User Limit.

A license can be “checked out” for up to thirty (30) days. Once “checked out,” the license is unavailable for
use by any other Users until the license is checked back “in.” An internet connection is not required to use
the software during the checkout period for the device and User that checked out the license.

Installing GASWorkS

An appropriate version of Windows must be running to install GASWorkS. If it is not, start Windows now,
then proceed with the installation process described below.

! Using the provided link, download the setup file (.exe) to your device. Using Windows File Explorer,
navigate to the file’s location.

! Double-click on the setup file name. If a Windows Security warning appears, allow your device to execute
the file.

! After the setup program has been started, several screens will be displayed during the installation process.
Read the contents of each screen carefully and respond appropriately.

 B3PE LLC                                                                                          Engineering & Software Services
Revision - 006, Copyright 2023, All Rights Reserved.



GASWorkS™ 10.1 Getting Started Guide

On the License Agreement screen, read the terms of the License Agreement carefully and select
the “I agree to...” option to continue. If you do not wish to accept the License Agreement, you
will not be able to continue with the installation process.

Note...

• An appropriate version of Windows must be running before GASWorkS may be executed. If
Windows is not running, begin its execution now.

• The device must be connected to the internet the first time that the GASWorkS software is
executed.

• On Windows Vista and newer devices, you will need to be logged on as the Full Administrator
or use the “Run as administrator” option the first time you execute the software.

Note...

! A message will be displayed when the installation process is complete. The message will indicate whether
the installation was successful or whether it failed. Select the appropriate option to clear the message.

Starting GASWorkS

! From the Windows Desktop, double-click the GASWorkS 10 shortcut icon.

! The GASWorkS software will be started, the Welcome screen will be displayed, and the license will be
checked.

! Review the displayed license information, and click the Continue command button to “check out” a license
and enter the software.

 B3PE LLC                                                                                          Engineering & Software Services
Revision - 006, Copyright 2023, All Rights Reserved.



GASWorkS™ 10.1 Getting Started Guide

If the device is not connected to the internet, a message stating that the software is “Unable To
Access Validation File” will be displayed. To proceed - connect the device to the internet, then
click the Retry command button.

Note...

Once installed, to become acquainted with the features of the GASWorkS software, we suggest you work
the example in the Demonstration Guide. The Demonstration Guide and other documentation can be viewed
and printed from the Help menu list.

User Limit

The number of Users that can simultaneously run the GASWorkS software depends on the number of User
licenses purchased. This number is referred to as the User Limit.

When GASWorkS is executed, it determines the User Limit associated with the license and the number of
Users currently using the software - the Current Users. The Welcome screen displays these values.

If the addition of a new User does not exceed the User Limit, the Continue command button will be enabled,
and you will be able to start GASWorkS. If the User Limit is exceeded by allowing a new User, you will not
be able to execute the GASWorkS software until one of the in-use licenses is returned.

Setting The Number Of Displayed Decimals

The number of digits displayed to the right of the decimal place can be specified by the User. The number
of displayed decimal places can be set by the Decimals data tab on the Report Options screen. The screen
is accessed by selecting the Report Options item from the Report menu. Select the desired number of digits
to display to the right of the decimal location for the associated item. Click the Close command button to
save and apply the changes.
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The example models provided with GASWorkS generally use US units of measure. To obtain
valid results, these examples must be worked using the US units. When working these examples,
if the default data values and dimensional units have been changed, they must be reset to their
original US values before working with the example model.

Note...

Notes On Dimensional Units

When GASWorkS first starts, its default dimensional units are set to standard US values (feet, inches, psi,
Fahrenheit). However, you will notice that the software supports a variety of dimensional units.

To change the default dimensional units, use the Default Data Values screen found from the Set Defaults item
in the Utilities menu. Select the Dimensional Units data tab to access the currently selected dimensional
units. Make any changes by selecting the desired item from the associated lists. Click the Apply Dimensional
Units Only command button to change the values used in the current model. Note - Do not click the Apply
All Values command button unless you are sure that you want to apply all of the default setting values on the
various data tabs to the current model.

As used in GASWorkS, all pressure units represent “gauge” units unless otherwise specified. Within the
documentation, gauge pressure units are generally shown without a suffix, and absolute pressure units are
shown with an “a” or “(Abs)” suffix. Gas volume values or volumetric flow rates are expressed in “standard”
cubic units, based on (adjusted to) the specified base pressure and temperature.

Notes For International Users

GASWorkS attempts to accommodate the needs of international Users by providing a robust set of
dimensional units. These units can be selected as appropriate for the User’s particular needs.

GASWorkS does have a particular weakness when it comes to the various Property Tables that contain
predefined data. These lists are primarily oriented toward US manufacturers and sizes. The Property Tables
can be easily modified by the User to more specifically meet the particular needs of each User. The Property
Tables provided with the software are intended to provide a starting point to allow the User to create their
own custom Property Tables.

GASWorkS can accommodate either a comma (,) or a dot (.) as the decimal identifier or a comma (,) or a dot
(.) as the digit grouping identifier, depending on the associated Windows setting. For example, ten thousand
and one-tenth may be displayed as “10,000.10” or as “10.000,10” depending on the Windows setting.

Use the Regional and Language options found in the Windows Control Panel to change the digit grouping
and decimal identification settings.
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Using The Help System

The help documents are stored on the B3PE server. You must be connected to the internet to access the
various GASWorkS help and support documents.

The GASWorkS Help Guide can be used to view examples and how-to tips on performing a specific task.
The GASWorkS User’s Manual can be used for information on specific screens and commands as well as
detailed instructions, descriptions, and explanations.

Once a document is opened, it can be saved locally if you wish. If you save a help document to your machine
for offline access, you will need to open it directly in your Portable Document Format (PDF) document
viewer. A suitable PDF document viewer or reader is required to view and print the documents.

The Help Menu

Access to the various help documents and information is provided in the Help menu. You can also view our
contact information, send a help request, or visit our website. Note - Some of the features require an internet
connection to work properly.

Contact Us

Hours: Our normal work hours are 8:00 A.M. to 5:00 P.M. Mountain Time, Monday through Friday.
However, if you have a problem, please try anytime - we may be in.

Telephone: (719) 578-9391

Email: help@b3pe.com

Website: www.b3pellc.com

Exiting GASWorkS

When the Continue command button is clicked on the Welcome screen to enter the software, a license of the
GASWorkS software is “checked-out.”

When exiting the GASWorkS software, there are two options - an option to “return” the checked out license
or an option to keep the license “checked-out.”
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If the Uninstall Program asks to remove any shared system files, click the No command button.
Note...

• On some devices, the Uninstall routine will not be able to remove any directory or file that has
been created after the initial installation.

• Some of the files and folders created by GASWorkS after the installation may include files in
the initialization directory (ini), files in the default model file directory (files), and files in the
application directory (app).

• To remove these files and folders, use Windows File Explorer to find and delete the remaining
files and folders. An example of the path for the initialization folder is shown below. The other
folders have similar path locations.

• 32-bit devices - C:\Program Files\GASWorkS 10\ini
• 64-bit devices - C:\Program Files (x86)\GASWorkS 10\ini

Note...

! To return the “checked-out” license, from the Exit GASWorkS submenu of the File menu, click
the And Return License item. In order to return the “checked-out” license, the device must be
connected to the internet so that the User Count can be updated.

! To keep the license “checked-out,” from the Exit GASWorkS submenu of the File menu, click the
Without Returning License item. The User Count will not be updated, and the license will remain
“checked-out” until the license is “returned.” This option allows for the software to be used without
having access to an internet connection for up to 30 days. Select the And Return License item from
the Exit GASWorkS submenu of the File menu to return a “checked out” license.

Uninstalling GASWorkS

If, after using the GASWorkS software, you wish to remove it, select the Uninstall GASWorkS item from the
Windows GASWorkS menu list.

! After the Uninstall Program has been started, read the contents of each screen carefully and respond
appropriately.

! A message will be displayed when the Uninstall routine is complete. The message will indicate whether
the uninstall process was successful or whether it failed. Select the appropriate option to clear the message.
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